blob: 0469b84388ec4349d94f1ba7e5d7ce509be3a585 [file] [log] [blame]
{
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem
(system:
let
pkgs = import nixpkgs {
inherit system;
};
in
{
devShell = pkgs.mkShell {
buildInputs = with pkgs; [
earthly
go
kubernetes-helm
nixpkgs-fmt
poetry
vendir
glibcLocales
bashInteractive
];
};
}
);
}