blob: a11b7617a902586ab3a93128a449eb3f6ccc1de4 [file] [log] [blame]
Mohammed Naser55ff4452023-11-28 22:34:47 -05001{
2 inputs = {
3 nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
4 flake-utils.url = "github:numtide/flake-utils";
5 };
6
7 outputs = { self, nixpkgs, flake-utils }:
8 flake-utils.lib.eachDefaultSystem
9 (system:
10 let
11 pkgs = import nixpkgs {
12 inherit system;
13 };
14 in
15 {
16 devShell = pkgs.mkShell {
17 buildInputs = with pkgs; [
Mohammed Naser25e5af22023-12-05 13:03:13 -050018 earthly
Mohammed Naser55ff4452023-11-28 22:34:47 -050019 vendir
20 ];
21 };
22 }
23 );
24}