blob: 293236ba83e6bf6aa0c083464fd1161667dd325e [file] [log] [blame]
Mohammed Naser55ff4452023-11-28 22:34:47 -05001{
2 inputs = {
3 nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
4 flake-utils.url = "github:numtide/flake-utils";
5 };
6
7 outputs = { self, nixpkgs, flake-utils }:
8 flake-utils.lib.eachDefaultSystem
9 (system:
10 let
11 pkgs = import nixpkgs {
12 inherit system;
13 };
14 in
15 {
16 devShell = pkgs.mkShell {
17 buildInputs = with pkgs; [
Mohammed Naserf75ab072024-04-02 12:55:10 -040018 bashInteractive
Mohammed Naser25e5af22023-12-05 13:03:13 -050019 earthly
Mohammed Naserf75ab072024-04-02 12:55:10 -040020 glibcLocales
Mohammed Naser12207172024-02-05 18:49:35 -050021 go
Mohammed Naserec58e2b2025-03-03 15:15:14 -050022 just
Mohammed Naser91e2fa02024-02-23 01:46:39 -050023 kubernetes-helm
Mohammed Naser12207172024-02-05 18:49:35 -050024 nixpkgs-fmt
Mohammed Naser2fd39612024-04-14 13:37:45 -040025 patchutils
Mohammed Naserf75ab072024-04-02 12:55:10 -040026 python311Packages.tox
Mohammed Naser40c2f912025-02-25 14:29:08 -050027 reno
Mohammed Naser7d15bf72025-03-13 22:14:03 -040028 renovate
Mohammed Naser55ff4452023-11-28 22:34:47 -050029 ];
30 };
31 }
32 );
33}